Problem:
Printers do not map in session after updating the Citrix Receiver. This causes the ThinPrint Client ICA to malfunction and therefore it does not load in the system tray.
Cause:
Depending on the installing user privileges and the client architecture, the relevant Citrix ICA Client registry path may have changed.
Applies to:
ThinPrint ICA Client (any version)
Citrix Receiver (any version)
Solution:
The easiest way to get the ThinPrint Client working again would be to perform a repair-installation of the ThinPrint Client after the Citrix Receiver update.