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Licensing Issues

Support Center/Knowledge Base/Troubleshooting/Licensing Issues

Timeout while synchronization

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Problem:
You receive an error message “timeout” while running a synchronization in 10.6. FR1. Most likely you observe this issue in larger customer environments with AD 1000+ users. 

Sync_Timeout.png

Cause:
By default there is a timeout of 90 seconds defined 10.6. FR1.
If the synchronization process takes longer than the specified time, then it will result in the error message stated above.

Workaround:
You can work around that issue by modifying the following value in ADSync.js from 9e4 (90 sec) to 9e5 (900sec / 15min). (C:\Program Files\ThinPrint License Server\WebApps\fm\CPAspects\ADSync.js)

[…]$.ajax({url:n+ADSyncAspect.getUrl()+”/TP/SyncAdamWithAD”,timeout:9e4, type:i,traditional:t,success:function(n){n.Success?[ …]

Solution:
You can also download this predefined ADSync.js where the timeout has been set to 15min.

  1. Copy ADSync.js to %PROGRAMFILES%\ThinPrint License Server\WebApps\fm\CPAspects\ADSync.js
  2. Restart IIS or recycle the IIS ApplicationPool “ThinPrint Administration Framework“
  3. Update the file TPPowershell.dll to version 10.6.103.x or higher.
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