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Licensing Issues

Support Center/Knowledge Base/Troubleshooting/Licensing Issues

Automatic licensing not working

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Problem:
This can be a sporadic issue.  When printing while licensing mode is “automatic” with Cortado License Server 10.6, user gets the error: “no valid license found.”

Cause:
Logs show “Access Denied” for the specific user.

The “cclus.log” file shows the following:
4/28 09:37:03:728 Id:10412 _TRC_/NORM connsvcd:189 LSync request with SID = ZFlorence, dom = , host = 04/28 09:37:03:838 Id:10412 _TRC_/NORM clvinterface:149 ADsOpenObj(WinNT://./ThinPrint Excluded Users) .. 04/28 09:37:05:513 Id:10412 _TRC_/NORM clvinterface:157 ADsOpenObj(WinNT://./ThinPrint Excluded Users) = 0x00000000 04/28 09:37:05:545 Id:10412 _ERR_/NORM xauthz:65 HRESULT = 0x80070005 04/28 09:37:05:545 Id:10412 _TRC_/NORM proc:1231 thread cleanup on exit 04/28 09:37:05:545 Id:10412 _TRC_/NORM proc:1250 thread exited (0x80070005) 04/28 09:37:15:473 Id:4392 _TRC_/NORM com#335 CCLUCS instance deleted

“AuthzInitializeContextFromSid” gets called in this context to verify a new user not being blacklisted (for licensing).

This is a problem in scenarios where a program running in the trusting domain tries to calculate a user’s permissions to a specific resource, based on AD group membership.

This fails if there is only a one-way, outgoing trust to the user’s domain.

Workaround:
Add user manually to the Cortado License Server (user was never added before)

Solution:
Since “Windows Authorization Access Group” is a built-in domain group, you will have to add the machine account running the CCLUCS to this group.

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Licensing Issues
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  • License Key is missing a Registration Key
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