Problem:
Suddenly printers on the Mac are not redirected via JumpDesktop using ThinPrint Client Mac for RDP.
Cause:
Usually it has to do with the fact that there is a conflict between the JumpDesktop virtual channel interface and the ThinPrint Client, so that the ThinPrint Client is no longer automatically loaded during session initialization.
Solution:
Install ThinPrint Client 12 for Mac RDP from our Download Page.
The new ThinPrint Client 12 for Mac RDP requires that you install Jump Desktop web version 8.8.28 and higher from the website first and not the version from the Apple App Store.