Problem:
Local printers are not mapping within a session. The error indicates “No template found”.
Cause:
The session host is missing the ThinPrint printer template (_#Thinprint Output Gateway printer)
Solution:
Recreate the printer template as follows:
- From within the Windows “Devices and Printers” console choose “Add Printer”
- Windows will search for an existing printer – select “The printer that I want isn’t listed.”
- Select “Add a local printer or network printer manually” and click “Next”
- Select “Use an existing port” and choose the “ThinPort (ThinPrint port)”
- In the list of printers, select “ThinPrint” under Manufacturers and then select the “TP Output Gatway” under Printer and click “Next.”
- Select “Replace existing driver” and click “Next.”
- Be sure to add the _# in FRONT of the printer name so it appears like this: _#TP Output Gateway (this is how ThinPrint knows this is a ThinPrint “template”)
- Once the printer has been created, open the “Printer Properties” dialogue for the TPOG and click on the “Security” tab.
- Add the SYSTEM account and give it full privileges.
- Remove the “Everyone” group if it exists (this ensures users don’t see each others printers). Click “OK” when you’re finished modifying the Security.
- Now that the template has been recreated, open the ThinPrint Configuration (Engine) and replace the existing template in the “Dynamic Printer Matrix” table with this new template.