Problem:
License information can’t be retrieved using ThinPrint License Manager. the License Manager shows a red cross on LOCALHOST (see image below).
Cause:
TPLicMMC relies on an hardcoded local IP address (127.0.0.1) to identify the local hostname. If 127.0.0.1 can’t be resolved via IPv4, the TPLicMMC fails to connect to its local WMI provider.
This is typically the case if IPv6 is in use. IPv6 is not yet supported by ThinPrint and therefore the connection to LOCALHOST can’t be established.
Workaround:
Modify the servers hosts file (%Systemroot%\System32\drivers\etc\hosts) to force the name resolution to deliver a IPv4 address for LOCALHOST (see entry below). By doing so you don’t need to disable IPv6 completely.
Entry in hosts file should read as follows:
127.0.0.1 localhost
Solution:
Update TPLicMMC.dll to version 9.4.398.x or higher.