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Mapping Issues

Support Center/Knowledge Base/Troubleshooting/Mapping Issues

Local printer mapping fails

4914 views 0

Problem

Users local printers do not map in Citrix session.

Cause

In some cases the ThinPrint ICA Client does not start with a XenApp session. This can happen during a new installation of the relevant components or during an update.

You will receive a corresponding error message in the ThinPrint Diagnostics Log.

Event ID 4002: Can’t connect to virtual channel (50)

Applies to product

ThinPrint Engine 10+

ThinPrint Client ICA 10+

Solution

In case the print protocol ICA is to be used, the installation sequence of the relevant components must be maintained as follows. Verify that both the Citrix Receiver and the ThinPrint Client are installed with administrator privileges.

Install order:

  • Install Citrix Receiver.
    • In the case of an update or reinstallation, please uninstall the old application and manually delete the folder C:\Program Files (x86)\Citrix before performing a reinstallation or update.
  • Start a XenApp session.
  • Install the ThinPrint ICA Client and finally log off once from the workstation.
  • Start a new XenApp session.
    • The TP ICA Client should now start automatically with a XenApp or XenDesktop session. (check TP Client Icon in System Tray)
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Tags:Issue_Printer Mapping

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