Problem
When sending a print job, the job does not print. It deletes itself from the ThinPrint queue.
Cause
This occurs often with when printing to printers with the HP UPD driver. The HP driver tries to access certain registry keys that are not accessible (in user context) on the central print server.
Applies to product
ThinPrint Engine (any version)
ThinPrint Engine (any version)
ThinPrint Desktop Engine (any version)
Solution
The registry needs to be modified to allow permissions in user context.
Caution: Before editing or changing anything in the Microsoft Windows registry, it’s recommended that you backup the registry.
HP Special Permissions
—————————————–
1. Open Regedit.
2. Open the Permissions of the registry key
“HKEY_USERS\.DEFAULT\Software \Hewlett-Packard”
3. For the group of users which should be able to print (e.g. Domain Users), add the
following special permissions
– Set Value
– Create Subkey
4. Restart spooler