• Products
  • Solutions
  • Partners
  • Resources
  • Support
  • Download
  • Buy Now
  • Products
  • Solutions
  • Partners
  • Resources
  • Support
  • Download
  • Buy Now

Mapping Issues

Support Center/Knowledge Base/Troubleshooting/Mapping Issues

Horizon Client and TP Client installed on same machine

1295 views 0

Problem:
Printers do not map, the TP Client won’t load.  When having ThinPrint Client, as well as VMware Horizon Client, installed on the same machine, printer mapping will fail for one or the other.   In addition, an error message pops up ‘Missing entry: Fork_RUNDLL’ when starting a VMware Horizon session.

NOTE: See the problem description and current workaround below. We are going to make sure this works out-of-the-box without modifications with the next ThinPrint Client release.


Cause:

You cannot have the latest VMware Horizon Client (currently 4.6.1) installed along with TP Client 11 without breaking virtual printing component of the VMware Horizon Client.  In addition, TP Client will not start when starting a Remote Desktop (mstsc) session


Workaround:
Make sure the Remote Desktop Client is closed as well as the Horizon Client BEFORE proceeding with the following tasks.

  1. Move the tpclnrdp.dll file from “C:\Windows\System32” to “C:\Program Files\Common Files\ThinPrint”
  2. Change the following registry values:

[HKEY_USERS\<USER_SID>\Software\Microsoft\Terminal Server Client\Default\AddIns\ThinPrint]
“Name” = “C:\Program Files\Common Files \ThinPrint\TPClnRDP.dll“

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Terminal Server Client\Default\AddIns\ThinPrint]
“Name” = “C:\Program Files\Common Files \ThinPrint\TPClnRDP.dll“

[HKEY_LOCAL_MACHINE\SOFTWARE\ThinPrint\tpclnrdp]
“SiSActive” = “0“

Step 2 and 3 via Powershell (Run as Administrator)

$RegPathTP = "HKLM:\Software\ThinPrint\tpclnrdp"
$RegPathTS = "HKLM:\Software\Microsoft\Terminal Server Client\Default\AddIns\ThinPrint"
$RegPathTSHKU = "REGISTRY::HKEY_USERS\*\Software\Microsoft\Terminal Server Client\Default\AddIns\ThinPrint"

Move-Item $env:SystemRoot\System32\tpclnrdp.dll $env:CommonProgramFiles\ThinPrint -EA Stop

Set-ItemProperty $RegPathTP -name "SiSActive" -Value 0 -force | Out-Null
Set-ItemProperty $RegPathTS -name "Name" -Value "$env:CommonProgramFiles\ThinPrint\TPClnRDP.dll" -force | Out-Null
Set-ItemProperty $RegPathTSHKU -Name "Name" -Value "$env:CommonProgramFiles\ThinPrint\TPClnRDP.dll" -force | Out-Null
Previous Page
Next Page
Tags:issueIssue_ErrorsIssue_Performance

Was this helpful?

Yes No
Related Articles
  • Printing and Printer mapping Issues after Windows Update
  • Printers not redirected anymore from Mac with JumpDesktop
  • Devices and Printers view is empty in Server 2012 OS
  • Printers are not mapping for some users in certain AD Groups
  • Printers do not map after updating Citrix Receiver

Mapping Issues
  • Printing and Printer mapping Issues after Windows Update
  • Printers not redirected anymore from Mac with JumpDesktop
  • Devices and Printers view is empty in Server 2012 OS
  • Printers are not mapping for some users in certain AD Groups
  • Printers do not map after updating Citrix Receiver
View All 12
Support Resources
  • Manuals & Guides
  • How To
  • FAQ
  • Troubleshooting
  • Supported Devices
  • Supported Versions

Request Support

Change Language
  • ENEN
  • DEDE
About ThinPrint
  • About Us
  • News Center
  • Press Room
  • Events & Webinars
  • Careers
  • Contact Us
Also Visit
ThinPrint Homepage
Products, services, and company information

ThinPrint Blog
Insights, expertise and ideas on printing

ezeep by ThinPrint Cloud Services
Enjoy the Ease of Cloud Managed Printing

Cortado Holding
ThinPrint is a 100% subsidiary of Cortado Holding
Contact Us
From the Americas: +1 303 487 1302
Mon – Fri from 11 a.m. to 7 p.m. (EST)/
8 a.m. to 4 p.m. (PST).

From the Asia Pacific Area: +61 2 8079 2989
Mon – Fri from 8.30 a.m. to 5.30 p.m. (AEST).
Support available in English only.

From all other areas: +49 30 39 49 31 0
Mon – Fri from 9 a.m. to 5 p.m. (CET).
Support available in English & German.

Or use our contact form »
  • © ThinPrint 2021 | Legal Notes & Data Protection