Problem
Enable ThinPrint Client logging via ThinPrint Diagnostic Utility does not create any client logs from the VMware View client.
Cause
- To enable ThinPrint logging on a current VMware View Client system, it is not possible to enable logging for the 64bit ThinPrint component via thinPrint Diagnostic Utility.
- Logging path is set to a directory where not every user has write and modify permissions.
Solution
Please make sure that the folder has write and modify permissions for all users. The ThinPrint components in the VMware Clients write the log data and thus, the user that is running the client is impersonated for writing the log data.
To enable ThinPrint Client logging on the VMware View Desktop machine, you have to modify the Windows registry.
This article provides steps to enable Client logging for ThinPrint in a VMware View Client System.
- Create logging path c:\temp\thinprint. Make sure the Logging path is set to a directory where every user has write and modify permissions. When in doubt, simply give Full Access permissions to ‘Everyone‘ for gathering the log data and roll back the setting afterwards if necessary.
- Click Start > Run, type regedit.exe, and click OK. The Registry Editor window opens.
- Navigate to the HKLM\SOFTWARE\ThinPrint\Client or create key if it not exists.
- Create a new String value and name it DebugFile and set its Value data to C:\temp\thinprint\TPClient.log.
- Create a new DWORD value and name it DebugLevel and set its Value data to 0x00000007.
- Navigate to the HKLM\SOFTWARE\ThinPrint\TPView or create key if it not exists.
- Create a new String value and name it DebugFile and set its Value data to C:\temp\thinprint\tpview.log.
- Create a new DWORD value and name it DebugLevel and set its Value data to 0x00000141.
Note: Close and restart the VMware View Client for the changes to take effect. When in doubt, reboot the View Client system.